current position:Home>ERROR: 1.13.4 is required to build Fabric and you are using . Please update go

ERROR: 1.13.4 is required to build Fabric and you are using . Please update go

2022-02-03 23:01:33 Q & A of Denglian community

1、 Based on the environment :centos7.5docker 1.13.4docker-compose 1.26.1GOPATH Environment variables are configured correctly 2、 problem : In the installation hyperledger fabric 2.0 when , The problems are as follows :

[[email protected] fabric]$ make allmake: go: Command not foundmake: go: Command not foundmake: go: Command not foundmake: go: Command not foundmake: go: Command not foundmake: go: Command not foundmake: go: Command not foundmake: go: Command not foundmake: go: Command not foundmake: go: Command not foundscripts/check_go_version.sh: line 8: go: command not foundERROR: 1.13.4 is required to build Fabric and you are using . Please update go.make: *** [check-go-version] Error 2

3、 The installation process :

  1. mkdir gopath/src/github.com/hyperledger
  2. git clone https://github.com/hyperledger/fabric.git
  3. cd fabric && git checkout release-2.0
  4. make all , Then the above error was reported





Other answers 1:


Other answers 2:

copyright notice
author[Q & A of Denglian community],Please bring the original link to reprint, thank you.
https://en.netfreeman.com/2022/02/202202032301311066.html

Random recommended